Doppelte Einträge in Excel-Tabellenblättern vermeiden

In Excel-Tabellenblättern werden oft Listen gepflegt, in denen in einer bestimmten Spalte nur eindeutige Werte enthalten sein dürfen. Denken Sie beispielsweise an eine Artikel-, Auftrags- oder Rechnungsübersicht, in der keine Artikel-, Auftrags- bzw. Rechnungsnummern doppelt vorkommen dürfen. Mit der Aktivierung von Gültigkeitsprüfungen können Sie verhindern, dass in einer Spalte ein Wert mehrfach eingegeben wird.

In der folgenden Auftragsliste soll sichergestellt werden, dass in der Spalte A in den Zeilen 2 bis 20 eine bestimmte Auftragsnummer nur einmal eingegeben werden kann.

Bild1

In Excel 2010 und Excel 2007 gehen Sie bitte folgendermaßen vor:

  1. Markieren Sie die Zellen A2 bis A20.
  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Datentools auf die Schaltfläche Datenüberprüfung
  3. Auf der Registerkarte Einstellungen wählen Sie im Dropdown-Feld Zulassen den Eintrag Benutzerdefiniert.
  4. Geben Sie im Feld Formel den folgenden Ausdruck ein: =ZÄHLENWENN($A$2:$A$20;A2)=1
  5. Klicken Sie auf die Registerkarte Fehlermeldung und prüfen Sie, ob die Option Fehlermeldung anzeigen, wenn ungültige Daten eingegeben wurden aktiviert ist.
  6. Wählen Sie im Feld Typ den Eintrag Stopp und geben Sie in den Feldern Titel und Fehlermeldung die Texte ein, die erscheinen sollen, wenn eine Auftragsnummer bereits vorhanden ist.

Wenn Sie in der Zelle A8 die Auftragsnummer 11 eingeben, wird die von Ihnen eingegebene Fehlermeldung erscheinen.

Achtung:

Die Gültigkeitsprüfung wird nur ausgeführt, wenn Sie eine Auftragsnummer eingeben. Falls Sie die Auftragsnummer über die Zwischenablage einfügen, findet keine Prüfung statt. Mit dem Einfügen wird sogar die Gültigkeitsprüfung gelöscht, wenn für die Quellzelle selbst keine Gültigkeitsprüfung eingerichtet wurde.

Möchten Sie nachträglich überprüfen, ob es in Ihrem Tabellenblatt Zellen mit doppelten Auftragsnummern gibt, klicken Sie auf der Registerkarte Daten in der Gruppe Datentools auf den Pfeil neben der Schaltfläche Datenüberprüfung und danach auf die Schaltfläche Ungültige Daten einkreisen.

Falls es in der Auftragsliste doppelte Auftragsnummern geben sollte, werden sie folgendermaßen gekennzeichnet:

Bild2

Um die roten Markierungen zu löschen, korrigieren Sie die doppelten Einträge in der Spalte A und löschen Sie die übrig gebliebenen Markierungen. Klicken Sie hierzu auf der Registerkarte Daten in der Gruppe Datentools auf den Pfeil neben der Schaltfläche Datenüberprüfung und danach auf die Schaltfläche Gültigkeitskreise löschen.

Hat Ihnen dieser Beitrag weitergeholfen?

ja nein Andere Erwartung

Geben Sie uns Ihr Feedback. Möchten Sie eine Antwort von uns erhalten, tragen Sie zusammen mit Ihrem Feedback auch Ihre E-Mail-Adresse ein. Ihre E-Mail-Adresse wird ausschließlich für die Kommunikation mit Ihnen verwendet. Sie wird nicht veröffentlicht oder weitergegeben.

Benötigen Sie professionelle Unterstützung beim Einsatz von Word, Excel, Outlook, PowerPoint oder Access, so sind wir der richtige Ansprechpartner für Sie. Senden Sie uns eine E-Mail mit einer kurzen Problembeschreibung. Jemand aus unserem Team wird sich bei Ihnen melden, um weitere Details abzuklären und Ihnen ein Angebot für unsere Dienstleistung zu erstellen.