Die Excel-Funktion SUMMEWENNS für bedingtes Addieren von Werten

Eine der Funktionen, die mit der Version Excel 2007 neu in den Funktionskatalog aufgenommen wurde, ist die Funktion SUMMEWENNS. Im Gegensatz zu der Funktion SUMMEWENN können Sie mit dieser Funktion einen Zellbereich von Werten addieren unter Berücksichtigung von bis zu 127 Bedingungen.

Die Funktion ist für 2 Bedingungen folgendermaßen aufgebaut:

=SUMMEWENNS(<Zellbereich, dessen Werte addiert werden sollen>;<erster zu prüfender Bereich;<erste Bedingung>;<zweiter zu prüfender Bereich>;<zweite Bedingung>)

Die Anwendung dieser Funktion soll an dem folgenden Beispiel gezeigt werden:

In der unteren Tabelle sind die Rechnungs- und Zahlungsbeträge von Kunden erfasst worden. Die Funktion SUMMEWENNS soll verwendet werden, um flexibel die Anzahl der überfälligen Beträge eines oder aller Kunden zu einem bestimmten Stichtag zu ermitteln:

SUMMEWENNS in Excel

Die Zellen mit dem gelben Hintergrund markieren die offenen Posten, die bis zum 22.01.2011 fällig waren und noch nicht beglichen wurden.

Die Formel für die Berechnung der Summe der überfälligen Beträge des Kunden Meyer zum Stichtag 22.01.2011 in Höhe von 310,00 € lautet folgendermaßen:

=SUMMEWENNS(F2:F10;A2:A10;"Meyer";C2:C10;"<=22.01.2011")

Diese Formel ist wie folgt zu lesen:

Addiere die Zahlen in dem Zellbereich F2 bis F10 nur, wenn in der gleichen Zeile im Zellbereich A2 bis A10 der Kunde Meyer erscheint und im Zellbereich C2 bis C10 ein Fälligkeitsdatum kleiner oder gleich dem 22.01.2011 enthalten ist.

Um die Formel flexibel verwenden zu können, sollten Sie den Namen des Kunden oder den Stichtag nicht als Konstanten in die Formel eintragen, sondern 2 Zellbezüge verwenden, in denen die Kriterien jeweils eingetragen werden:

SUMMEWENNS in Excel

Wenn Sie in der Zelle A14 den Namen des Kunden und in Zelle B14 das Kriterium für den Stichtag eingeben, lautet die Formel für die Ermittlung der überfälligen Beträge in Zelle C14 wie folgt:

=SUMMEWENNS(F2:F10;A2:A10;A14;C2:C10;B14)

Sie können in Zelle B14 auch als Stichtag das aktuelle Tagesdatum verwenden. Geben Sie dazu in Zelle B14 die folgende Formel ein:

="<=" &TEXT(HEUTE();"TT.MM.JJJJ")

Wenn Sie die überfälligen Beträge eines Kunden für Rechnungen ermitteln möchten, die in einen bestimmten Zeitraum fallen, können Sie die folgende Formel verwenden (siehe Zelle D17)

=SUMMEWENNS(F2:F10;A2:A10;A17;C2:C10;B17;C2:C10;C17)

Hinweise:

  • Falls Sie die Summe der überfälligen Beträge für alle Kunden sehen möchten, brauchen Sie in der Zelle A14 nur das Platzhalterzeichen * einzugeben.

  • Wenn Sie in der Zelle A14 den Ausdruck <>Meyer eingeben, wird die Summe aller überfälligen Beträge für die Kunden berechnet, die nicht Meyer heißen.

  • Die Anzahl der Zeilen und Spalten für den Zellbereich, der addiert werden soll, muss gleich sein der Anzahl der Zeilen und Spalten aller Kriterienbereiche. Ansonsten erscheint in der Formelzelle der Ausdruck #WERT.

Sie können hier die Beispieldatei herunterladen, um so einen besseren Zugang zu der Funktion SUMMEWENNS zu bekommen.

Hat Ihnen dieser Beitrag weitergeholfen?

ja nein Andere Erwartung

Geben Sie uns Ihr Feedback. Möchten Sie eine Antwort von uns erhalten, tragen Sie zusammen mit Ihrem Feedback auch Ihre E-Mail-Adresse ein. Ihre E-Mail-Adresse wird ausschließlich für die Kommunikation mit Ihnen verwendet. Sie wird nicht veröffentlicht oder weitergegeben.

Benötigen Sie professionelle Unterstützung beim Einsatz von Word, Excel, Outlook, PowerPoint oder Access, so sind wir der richtige Ansprechpartner für Sie. Senden Sie uns eine E-Mail mit einer kurzen Problembeschreibung. Jemand aus unserem Team wird sich bei Ihnen melden, um weitere Details abzuklären und Ihnen ein Angebot für unsere Dienstleistung zu erstellen.