Die Excel-Funktion SVERWEIS mit variabler Tabellenangabe

Die Funktion SVERWEIS wird in der Regel verwendet, um in einer Tabelle in der ersten Spalte nach einem Ausdruck zu suchen und einen Wert aus einer anderen Spalte der Tabelle abzurufen. Die Tabelle, in der gesucht wird, ist meistens fest vorgegeben. In diesem Tipp zeigen wir Ihnen, wie der Zellbereich, in dem gesucht wird, variabel gehalten werden kann.

In dem Beispiel soll für diverse Kunden der Rabatt ermittelt werden, den sie auf aktuelle Bestellungen erhalten. Der Rabatt ist abhängig von der Einordnung des Kunden in eine Kundengruppe und den Abnahmemengen des Vorjahres. Für jede Kundengruppe gibt es eine eigene Rabattstaffel mit unterschiedlichen Mindestabnahmemengen und Rabattsätzen. Das Tabellenblatt mit der Rabattberechnung sieht folgendermaßen aus:

Rabattberechnung mit SVerweis

Es gibt zwei Kundengruppen A und B. Die Rabattstaffel für Kunden der Kundengruppe A befindet sich im rot umrandeten Zellbereich F3:G6. Der Zellbereich hat den Namen Kundengruppe_A. Der grün umrandete Zellbereich F10:G13 hat den Namen Kundengruppe_B und enthält die Rabattkonditionen für die zweite Kundengruppe B. Für jeden Kunden soll nun im Zellbereich D2:D5 der ihm zustehende Rabatt aufgrund der Abnahmemengen des Vorjahres und der zugeordneten Kundengruppe ermittelt werden. Die Formel ist eine Kombination der Funktion SVERWEIS und INDIREKT. Die Formel für Kunde 1 lautet folgendermaßen:

=SVERWEIS(C2;INDIREKT("Kundengruppe_"&B2);2;WAHR)

Die Funktion INDIREKT stellt den Schlüssel für die variable Angabe der Tabelle dar, in der nach dem Rabattsatz gesucht wird. Mit der Funktion INDIREKT können Sie einen Bezug an die Funktion SVERWEIS geben, der als Text angegeben werden kann. In diesem Fall wird die Tabelle zusammengesetzt aus dem Begriff Kundengruppe_ und der Kundengruppe, die in der Spalte B der gleichen Zeile steht. Entscheidend für die variable Tabellenangabe in der Funktion SVERWEIS ist die Benennung der beiden Zellbereiche mit den Rabattstaffeln nach dem gleichen Muster, so dass mit der Funktion INDIREKT der Tabellenname zusammengesetzt werden kann.

Wenn Sie die Formel in Zelle D2 für die anderen Kunden nach unten kopieren, sieht das Tabellenblatt folgendermaßen aus:

Rabattberechnung mit SVerweis

Hinweise

  • Die Formel kann unverändert bleiben, wenn Sie statt zwei noch mehrere Kundengruppen mit unterschiedlichen Rabattstaffeln nutzen möchten. Sie brauchen nur die die weiteren Zellbereiche nach dem gleichen Muster benennen. Der Einsatz der INDIREKT-Funktion ist übersichtlicher als der alternative Einsatz ineinander geschachtelter WENN-Funktionen.
  • Wenn die Tabelle in der Formel mit dem SVERWEIS nicht gefunden wird, erscheint in der Ergebniszelle ein Fehler vom Typ #BEZUG!.
  • Die folgende Formel für Kunde 1 ohne die Funktion INDIREKT erzeugt einen Fehler vom Typ #WERT!:
    =SVERWEIS(C2;"Kundengruppe_"&B2;2;WAHR)

Hat Ihnen dieser Beitrag weitergeholfen?

ja nein Andere Erwartung

Geben Sie uns Ihr Feedback. Möchten Sie eine Antwort von uns erhalten, tragen Sie zusammen mit Ihrem Feedback auch Ihre E-Mail-Adresse ein. Ihre E-Mail-Adresse wird ausschließlich für die Kommunikation mit Ihnen verwendet. Sie wird nicht veröffentlicht oder weitergegeben.

Benötigen Sie professionelle Unterstützung beim Einsatz von Word, Excel, Outlook, PowerPoint oder Access, so sind wir der richtige Ansprechpartner für Sie. Senden Sie uns eine E-Mail mit einer kurzen Problembeschreibung. Jemand aus unserem Team wird sich bei Ihnen melden, um weitere Details abzuklären und Ihnen ein Angebot für unsere Dienstleistung zu erstellen.